Partial service outage

Incident Report for Faslet

Resolved

Due to an unexpected change in AWS's networking, several of our services we intermittently timing out. The issue has now been mitigated, and we will monitor closely.
Posted Sep 01, 2025 - 10:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 01, 2025 - 07:15 UTC
This incident affected: Widget, Partner Portal, Public API, Analytics & Data and Other Services (Product Feeds, Returns).